Disk Drive Problem

TI-99/4A Hardware problems, questions, etc.

Disk Drive Problem

Postby tcb » February 19th, 2011, 1:48 pm

Hi to all. Long time TI user but new to the board. I am experiencing a problem with my disk drives. I have the CorComp 9900 FDC. When I try to load Disk Manager the access lights comes on in order (drive 1, 2, 3, 4 ...3 and 4 are the ram disk) but the drives do not spin. The drives are 2 1/2 height Fujitsu's in the PEB. The ones Tex-Comp sold. Both were purchased and installed at the same time. I did some investigating myself. I pulled the drives out of the PEB and checked the connections...no problem there. I disconnected 1 Molex connector and plugged it into a spare DVD rom drive I have just to see if the power was OK. The rom drive worked as far as I could press the button and the tray would open and close and the light came on. OK....getting power. I reconnected the Molex to the floppy and turned on the PEB again. Still couldn't read. With the Floppys still partially out of the PEb I turned the power off again and noticed that the drives spun for about 1 second. That suggested to me that the drives are OK (motors working). So it would seem that the FDC might be the culprit. I opened the clamshell to see if there was anything obviously wrong but everything looked OK (no carmel colored burn marks near any components and no exploded resistors etc.). I've gone as far as I can in my investigation. Anybody have any idea what might be wrong and if it's the FDC is anyone still fixing them? I haven't used my TI for a long time since I bought a modern computer 10 years ago (that's already outdated too) but I would like to start using it again occasionally. Any help greatly appreciated. Thanks.
Posts: 1
Joined: February 19th, 2011, 12:57 pm

Re: Disk Drive Problem

Postby Ben Yates » February 20th, 2011, 4:00 am

Hmm... the drive lights stay on? Then your cable is reversed.
Doesn't stay on?

Then check to make sure the drives are setup properly. Check for a resistor pack on both drives. Are these on the same cable? The nearest should have the resistor pack removed, the next should have one. Maybe you connected them in the wrong order.

Make sure the Device Selects are different. DS can start at 0 (DS0) or 1 (DS1) depending on model. The drive you want as DSK1 should have its drive select at the lowest number, the DSK2 should be the next - unless you want it DSK3 for some odd reason.

Do you have a Disk Manager II cartridge? Maybe the disk is bad - I am assuming of course you are trying to load the Corcomp disk manager from Drive 1? A Disk Manager II cartridge would allow you to attempt access to that disk and return a confusing I/O error, until you decode the two digit error using either a Disk Manager manual or the User's Reference Guide. This will tell us something.

If you have a DM II cartridge, do you have spare disks? Make sure they are not HD disks, those won't work. If you don't know, a general rule of thumb is to look for a hub ring in the center of the disk. If the disk is not reinforced with a hub ring, it is likely it is an HD disk (this isn't 100%). If it isn't an HD, and you have a DMII, try a disk test on it. It will give you another confusing error code, which will require the DMII manual to decode.

Have you tried cleaning your drive heads? You have a disk cleaner? Or use a cotton swab dipped in alcohol - this may require access to the internals of the drive.

Good luck, report back!
Ben Yates
Posts: 35
Joined: January 25th, 2011, 4:11 am

Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest