99er Forums

Full Version: Please help diagnose my Ti
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi everybody. I picked up a TI-99/4A at a garage sale and was looking forward to playing around with it. Unfortunately, it looks as though it has a few problems. the TI splash screen comes up but the text is garbled. 

Ive attached a photo of the screen. Any ideas? not afraid to break out the soldering iron
(01-31-2019, 11:56 PM)kullboys Wrote: [ -> ]Hi everybody. I picked up a TI-99/4A at a garage sale and was looking forward to playing around with it. Unfortunately, it looks as though it has a few problems. the TI splash screen comes up but the text is garbled. 

Ive attached a photo of the screen. Any ideas? not afraid to break out the soldering iron

I don't see the attachment....

Does it work other than the display issue?  I'm not an expert but I've seen a couple threads on other forums about the video RAM chips going bad and that seems to typically result in a working console but corrupt display.

Check out these links:
http://www.vcfed.org/forum/showthread.ph...ay-problem

http://www.vcfed.org/forum/showthread.ph...n-TI-99-4A

http://www.99er.net/phbbarchive/99er.net...f=7&t=1182

http://atariage.com/forums/topic/231561-...solutions/

http://atariage.com/forums/topic/262461-ti994a-repair/
Thanks for the great post you posted. I like the way you describe the unique content. The points you raise are valid and reasonable. I am a tech support expert telling you about
norton.com/setup | mcafee.com/activate | turbotax support number[url=https://t-telstra.com/][/url]